clarketowson
Posts: 2
Joined: Fri Oct 29, 2021 1:32 am

Bitcoin dot com Wallet version 4.3.0 error message "Could not update wallet: Error querying the blockchain"

Fri Oct 29, 2021 2:20 am

Hello everyone,

I'm experiencing some technical difficulties with my Bitcoin dot com wallet and I thought I would post here about it as others may be experiencing the same issues at the moment and someone from Bitcoin dot com perhaps should take a look at what's happening and resolve the issue.

I have a Bitcoin dot com wallet version 4.3.0 which I installed on my Macbook Pro back in 2018 when I upgraded from the earlier version 3.5.6 which I installed in early 2017. Yesterday when I opened the wallet I received an error message "Could not update wallet: Error querying the blockchain". This error is present for my Bitcoin Core (BTC) wallet. My Bitcoin Cash (BCH) wallet I do not receive this error message.

The commit hash of the wallet link takes me to the Bitcoin Wallet github link:
https://github dot com /bitcoin-com/wallet/tree/977b715

When I go into settings and my wallet the wallet service url is: https://bws.bitcoin dot com /bws/api

I attempted to go to the https://bws.bitcoin dot com /bws/api URL in my browser and I receive an error message "Cannot GET /bws/api"

I still also have version 3.5.6 of the wallet installed and it gives the same error message as does v3.6.0 and v4.2.0 and version 5.4-hotfix1 which I also have installed.

I don't think that URL is the cause of the issue because when I look at my Bitcoin Cash wallet which is displaying the balance correctly and can access the blockchain it has a service URL https://bwsbcc.bitcoin dot com /bws/api which displays the same error message "Cannot GET /bws/api".

I have been considering upgrading my wallet for some time now but just have not got around to doing it. I assume there would be other people in the same position as me with old wallets perhaps with substantial sums in them which when they receive such an error message they may panic and not understand what's going on.

If these versions of the wallet have reached end of life which I assume they have it might be a good idea to resolve the broken URL: https://www.bitcoin dot com /wallet-support which is the URL that is reached when going into the wallets settings in the version 4.3.0 and clicking on the "Help & Support" section. A message could be placed on that page encouraging users to upgrade their wallet and instructing them on the steps to do this. Further instructions could be added specifically talking about this issue and advising the user that they have not lost funds and what they need to do.

I will be ex patting shortly and living overseas. I keep my Bitcoin dot com wallet seed phrase and wallet backup off site in a safety deposit box. Being here in Australia at the moment and having this issue with my Bitcoin dot com wallet it's not a huge deal if it's not fixed as I could just go to my safety deposit box, get my seed phrase and set up a new wallet pretty quickly. If I was overseas however and the issue was not fixed it would be a big problem for me which is why I may take my seed phrase with me and get a safety deposit box overseas as well. If I was overseas and did not have my seed phrase and the issue was not fixed this would be a massive problem for me.

It would be great if a Bitcoin dot com representative / developer could please take a look and see what's going on with the "Could not update wallet: Error querying the blockchain" error message and resolve it.

Please let me know if any more info is required.

Kind Regards,

Clarke

User avatar
jaxtan
Global Moderator
Global Moderator
Posts: 9
Joined: Mon Jul 15, 2019 10:28 am

Donate BTC of your choice to 1PpsL9cz3HKwRyqgsdWjcW22YkZexve1Ny

Contact: Telegram

Re: Bitcoin dot com Wallet version 4.3.0 error message "Could not update wallet: Error querying the blockchain"

Fri Oct 29, 2021 6:06 am

Hi there Clarke,

Good day! We are sorry to hear that you are having trouble with your Bitcoin.com wallet app.
Can you send us a message to wallet@bitcoin.com for us to take a look at everything and help you troubleshoot? We can also see that you are using the old version of the wallet app. We would like to help you, so that you can install the newest version of the wallet app.

We are looking forward to your message. Have a great day!

Best regards,
Jax
Image Play at the best provably fair Bitcoin games site here:
games.bitcoin.com

clarketowson
Posts: 2
Joined: Fri Oct 29, 2021 1:32 am

Re: Bitcoin dot com Wallet version 4.3.0 error message "Could not update wallet: Error querying the blockchain"

Fri Oct 29, 2021 6:12 am

Thanks Jax I have emailed you as suggested,

Kind Regards,

Clarke

Return to “Technical Support”

Who is online

Users browsing this forum: peaceandlove and 0 guests